Multiplayer Games not working between workstations

Post Reply
Posts: 11
Joined: Fri Nov 16, 2018 5:28 am

Multiplayer Games not working between workstations

Post by DisAster » Fri Nov 16, 2018 5:49 am

I've been using multiple machines along with multiple copies of Aster to host LAN parties. About 30% of the games that I try to install end up not working due to networking issues with workstations on the same physical computer. (they work on individual workstations, between physical machines, but they do not work on workstations on the same machine)

I have tried a variety of solutions in an attempt to resolve this.

First, I have tried setting up multiple IP addresses on the same network adapter, and assigning those addresses to specific workstations.
Next, I have tried using that configuration, in combination with ForceBindIP ( to bind specific IP addresses to specific applications. (I believe that's exactly what Aster's IP bindings do, so I really wasn't expecting this to work, but I gave it the old college try.)
Next, I tried running the programs in individual sandboxes using Sandboxie. (
Next I tried installing multiple, physical network adapters. (Tried both USB adapters, as well as a 4 port NIC)

Here's an incomplete list of games that I have tried:
Age of Wonders
Age of Wonders 2
Carmageddon Max Damage
Deadlock 2 Shrine Wars
Dungeon Keeper 2
Flatout 2
IL-2 Sturmovik
Titan Quest Anniversary Edition

I'm thinking that I need to find some kind of IP Socket monitor and redirector. Does anyone know of such a beast?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest